Kandi Kisses

Product Requirements
Poser 5 and above, Daz Studio3 and below, Victoria 4, Morphs ++, Elite, A4/G4/S4

Read more description:
http://www.renderosity.com/mod/bcs/index.php?ViewProduct=88321

Similar products

Tags:
1 Comment
  1. crafty66095 3 years ago

    Could you please reupload Kandi Kisses!
    Thanks so much!

Leave a reply

Log in with your credentials

Forgot your details?