Core Collection CYGoggles

A small set of 5 cyber goggles for your dystopian, urban adventures, or sci fi settings needs for Victoria 4.2.

Product Requirements: Victoria 4.2, Poser 5 and up

Read more description:
http://www.renderosity.com/mod/bcs/index.php?ViewProduct=71809

Similar products

Leave a Reply